Dell vCenter Management plugin 1.7 and server iDRAC updates error

If you run iDRAC updates on your VMware hosts you might run in to this error with the Dell Management plug-in for VMware vCenter. “Fail – Unable to contact iDRAC. Check iDRAC credentials and network connectivity”.

capture3

 

 

 

 

 

I ran in to this when upgrading the iDRAC from 2.30.30 to 2.40.40. I was able to log in to the iDRAC directly and ping the iDRAC from the Dell virtual appliance. The Dell vCenter plugin was the only thing that could not log on to the host iDRAC. The issue turned out to be located in the iDRAC settings under network/services. The web server needs to be set to TLS 1.0.

capture4

 

 

 

 

 

Unfortunately the Dell OMI only works with 1.0, but they hope to have it upgraded in the future.

So your option is to change the TLS settings in the iDRAC or leave your iDRAC firmware lower than 2.40.40.